Awesome Open Source
Awesome Open Source

Homebrew Tap for PHP extensions

brew tap shivammathur/extensions

Build status Build status LICENSE PHP Versions Supported macOS architectures supported macOS architectures supported

Extensions

Extension PHP Version
amqp PHP 5.6 to PHP 8.2
apcu PHP 5.6 to PHP 8.2
expect PHP 5.6 to PHP 8.2
grpc PHP 5.6 to PHP 8.2
igbinary PHP 5.6 to PHP 8.2
imagick PHP 5.6 to PHP 8.2
imap PHP 5.6 to PHP 8.2
memcache PHP 5.6 to PHP 8.2
memcached PHP 5.6 to PHP 8.2
mongodb PHP 5.6 to PHP 8.2
msgpack PHP 5.6 to PHP 8.2
pcov PHP 7.1 to PHP 8.2
pecl_http PHP 5.6 to PHP 8.2
phalcon3 PHP 5.6 to PHP 7.3
phalcon4 PHP 7.2 to PHP 7.4
propro PHP 5.6 to PHP 7.4
protobuf PHP 5.6 to PHP 8.2
psr PHP 5.6 to PHP 8.2
raphf PHP 5.6 to PHP 8.2
rdkafka PHP 5.6 to PHP 8.2
redis PHP 5.6 to PHP 8.2
ssh2 PHP 5.6 to PHP 8.2
swoole PHP 5.6 to PHP 8.2
vips PHP 7.0 to PHP 8.2
xdebug PHP 5.6 to PHP 8.2
xdebug2 PHP 7.2 to PHP 7.4
xlswriter PHP 7.0 to PHP 8.2
yaml PHP 5.6 to PHP 8.2
zmq PHP 5.6 to PHP 8.2

OS Support

Operating System Architecture
Linux 4.18+ x86_64
macOS Catalina x86_64
macOS Big Sur x86_64, arm64
macOS Monterey x86_64, arm64
  • On Linux, GLIBC 2.27 or newer is required, so distributions with Linux kernel 4.18 and newer are supported. For example: Ubuntu 18.04, Debian 10, CentOS 8, Fedora 28, and newer versions of these distributions.

  • All extensions except imap and vips are built on Linux.

Usage

Prerequisites

  • Update homebrew and the formulae:
brew update
  • Check that the required PHP version is installed. This tap works with PHP from both shivammathur/php tap and homebrew/core tap:
php -v
  • If not, install the required PHP version, For example to install PHP 7.4:
brew tap shivammathur/php
brew install shivammathur/php/[email protected]
brew link --force --overwrite [email protected]

Refer to shivammathur/php tap for more information about installing PHP.

Install PHP Extensions

  • Add Tap shivammathur/extensions:
brew tap shivammathur/extensions
  • Then install the required extension. See Formula directory for available formulae.

  • For example, to install Xdebug on PHP 7.4:

brew install [email protected]

Upgrade extensions

  • For example, to upgrade Xdebug on PHP 7.4.
brew upgrade [email protected]

Debugging

  • Make sure you ran brew update before installing PHP.

  • Run brew doctor and fix the warnings it reports.

  • Make sure homebrew has correct permissions.

sudo chown -R "$(id -un)":"$(id -gn)" $(brew --prefix)
  • Check if your issue is a Homebrew's common issue.

  • If you are still facing an issue, please create a discussion thread here.

License

The code in this project is licensed under the MIT license. Please see the license file for more information. This project has multiple dependencies. Their licenses can be found in their respective repositories.

Contributions

Contributions are welcome! Please see Contributor's Guide before you start. If you face any issues while using this tap or want to suggest a feature/improvement, create an discussion thread here.

Related Projects

Dependencies

Extensions

Homebrew

Formulae dependencies


Get A Weekly Email With Trending Projects For These Topics
No Spam. Unsubscribe easily at any time.
Php (404,422
Ruby (312,071
Hacktoberfest (33,731
Redis (6,737
Http (5,602
Grpc (2,247
Homebrew (1,395
Protobuf (1,285
Swoole (544
Amqp (540
Memcached (434
Imap (328
Homebrew Tap (223
Msgpack (207
Xdebug (177
Related Projects