Awesome Open Source
Awesome Open Source

CVE-2018-4407 Massive IOS/MAC Attack Exploit

CVE-2018-4407 is a Simple and Very Fast BOF attack Against IOS/MAC that can lead to DOS. The vulnerability is a heap buffer overflow in the networking code in the XNU operating system kernel. XNU is used by both iOS and macOS, which is why iPhones, iPads, and Macbooks are all affected.

Usage
apt-get install nmap
git clone https://github.com/r3dxpl0it/CVE-2018-4407.git && cd CVE-2018-4407 && pip install -r requirements.txt
Options :
usage: test.py [-h] [-s IP] [-p PLAYLOAD] target

positional arguments:
  target                Target Ip or Network Ip Range

optional arguments:
  -h, --help            show this help message and exit
  -s IP, --sourceip IP  Source Ip Adress
  -p PLAYLOAD, --payload PLAYLOAD
                        Number of Payload Loop
  • "PlayLoad" is Not a Miss-Type Nor a Mistake, Just a Joke ;)
Screen :
  • This ScreenShot Has Been Taken from the "Virtual Lab". [CVE-2018-4407]
Disclaimer :
  • Read The Licence

Get A Weekly Email With Trending Projects For These Topics
No Spam. Unsubscribe easily at any time.
Python (1,120,001
Ios (19,241
Macos (8,911
Security (8,729
Network (3,644
Hacking (2,341
Cybersecurity (1,409
Exploit (1,063
Hacking Tool (884
Penetration Testing (803
Poc (595
Redteam (520
Cve (344
Attack (327
Blueteam (170
Related Projects