Awesome Open Source
Awesome Open Source

webpack-babel-env-deps

Find dependencies to transpile with Babel.

📖 Read the docs!

A webpack helper to find dependencies of your project that require transpilation with Babel (and @babel/preset-env) by comparing your minimum Node.js engine against theirs (engines in package.json), and/or by determining their minimum Node.js engine or published ES2015/ES6+ source (module/jsnext:main in package.json) to require features provided by plugins and polyfills from @babel/preset-env.


Get A Weekly Email With Trending Projects For These Topics
No Spam. Unsubscribe easily at any time.
javascript (70,419
webpack (1,158
js (547
es6 (527
babel (357
es2015 (95
dependencies (61
transpiler (56
es7 (37
dependency (28
es2016 (17